Free Dec-2023 Professional-Cloud-DevOps-Engineer Dumps are Available for Instant Access
View All Professional-Cloud-DevOps-Engineer Actual Exam Questions Answers and Explanations for Free
Google Professional-Cloud-DevOps-Engineer exam is a certification provided by Google Cloud that assesses the skills and knowledge of professionals in the field of cloud-based DevOps engineering. Google Cloud Certified - Professional Cloud DevOps Engineer Exam certification is designed for individuals who have experience in using Google Cloud technologies to deliver and manage applications and services in a DevOps environment. Professional-Cloud-DevOps-Engineer exam evaluates the candidate's proficiency in designing, deploying, and maintaining cloud-based solutions using Google Cloud tools and services.
The Google Professional-Cloud-DevOps-Engineer exam consists of multiple-choice questions that test the candidate's knowledge and understanding of various cloud computing concepts and tools. Professional-Cloud-DevOps-Engineer exam is designed to assess the candidate's ability to design and implement scalable and secure cloud solutions using best practices and industry standards. Professional-Cloud-DevOps-Engineer exam takes approximately two hours to complete, and candidates must achieve a passing score of 70% or higher to receive certification. The Google Professional-Cloud-DevOps-Engineer certification is a valuable credential for professionals who want to demonstrate their expertise in cloud DevOps engineering and advance their careers in this field.
NEW QUESTION # 62
You support a popular mobile game application deployed on Google Kubernetes Engine (GKE) across several Google Cloud regions. Each region has multiple Kubernetes clusters. You receive a report that none of the users in a specific region can connect to the application. You want to resolve the incident while following Site Reliability Engineering practices. What should you do first?
- A. Use Stackdriver Monitoring to check for a spike in CPU or memory usage for the affected region.
- B. Reroute the user traffic from the affected region to other regions that don't report issues.
- C. Use Stackdriver Logging to filter on the clusters in the affected region, and inspect error messages in the logs.
- D. Add an extra node pool that consists of high memory and high CPU machine type instances to the cluster.
Answer: C
NEW QUESTION # 63
Your team is designing a new application for deployment into Google Kubernetes Engine (GKE). You need to set up monitoring to collect and aggregate various application-level metrics in a centralized location. You want to use Google Cloud Platform services while minimizing the amount of work required to set up monitoring. What should you do?
- A. Publish various metrics from the application directly to the Slackdriver Monitoring API, and then observe these custom metrics in Stackdriver.
- B. Install the Cloud Pub/Sub client libraries, push various metrics from the application to various topics, and then observe the aggregated metrics in Stackdriver.
- C. Emit all metrics in the form of application-specific log messages, pass these messages from the containers to the Stackdriver logging collector, and then observe metrics in Stackdriver.
- D. Install the OpenTelemetry client libraries in the application, configure Stackdriver as the export destination for the metrics, and then observe the application's metrics in Stackdriver.
Answer: A
Explanation:
https://cloud.google.com/kubernetes-engine/docs/concepts/custom-and-external-metrics#custom_metrics
https://github.com/GoogleCloudPlatform/k8s-stackdriver/blob/master/custom-metrics-stackdriver-adapter/README.md Your application can report a custom metric to Cloud Monitoring. You can configure Kubernetes to respond to these metrics and scale your workload automatically. For example, you can scale your application based on metrics such as queries per second, writes per second, network performance, latency when communicating with a different application, or other metrics that make sense for your workload. https://cloud.google.com/kubernetes-engine/docs/concepts/custom-and-external-metrics
NEW QUESTION # 64
You are creating and assigning action items in a postmodern for an outage. The outage is over, but you need to address the root causes. You want to ensure that your team handles the action items quickly and efficiently. How should you assign owners and collaborators to action items?
- A. Assign multiple owners for each item to guarantee that the team addresses items quickly
- B. Assign collaborators but no individual owners to the items to keep the postmortem blameless.
- C. Assign one owner for each action item and any necessary collaborators.
- D. Assign the team lead as the owner for all action items because they are in charge of the SRE team.
Answer: C
Explanation:
https://devops.com/when-it-disaster-strikes-part-3-conducting-a-blameless-post-mortem/
NEW QUESTION # 65
You have a CI/CD pipeline that uses Cloud Build to build new Docker images and push them to Docker Hub. You use Git for code versioning. After making a change in the Cloud Build YAML configuration, you notice that no new artifacts are being built by the pipeline. You need to resolve the issue following Site Reliability Engineering practices. What should you do?
- A. Disable the CI pipeline and revert to manually building and pushing the artifacts.
- B. Upload the configuration YAML file to Cloud Storage and use Error Reporting to identify and fix the issue.
- C. Run a Git compare between the previous and current Cloud Build Configuration files to find and fix the bug.
- D. Change the CI pipeline to push the artifacts to Container Registry instead of Docker Hub.
Answer: A
NEW QUESTION # 66
You are performing a semiannual capacity planning exercise for your flagship service. You expect a service user growth rate of 10% month-over-month over the next six months. Your service is fully containerized and runs on Google Cloud Platform (GCP). using a Google Kubernetes Engine (GKE) Standard regional cluster on three zones with cluster autoscaler enabled. You currently consume about 30% of your total deployed CPU capacity, and you require resilience against the failure of a zone. You want to ensure that your users experience minimal negative impact as a result of this growth or as a result of zone failure, while avoiding unnecessary costs. How should you prepare to handle the predicted growth?
- A. Because you are deployed on GKE and are using a cluster autoscaler. your GKE cluster will scale automatically, regardless of growth rate.
- B. Verity the maximum node pool size, enable a horizontal pod autoscaler, and then perform a load test to verity your expected resource needs.
- C. Proactively add 60% more node capacity to account for six months of 10% growth rate, and then perform a load test to make sure you have enough capacity.
- D. Because you are at only 30% utilization, you have significant headroom and you won't need to add any additional capacity for this rate of growth.
Answer: B
Explanation:
https://cloud.google.com/kubernetes-engine/docs/concepts/horizontalpodautoscaler The Horizontal Pod Autoscaler changes the shape of your Kubernetes workload by automatically increasing or decreasing the number of Pods in response to the workload's CPU or memory consumption
NEW QUESTION # 67
You are developing a strategy for monitoring your Google Cloud Platform (GCP) projects in production using Stackdriver Workspaces. One of the requirements is to be able to quickly identify and react to production environment issues without false alerts from development and staging projects. You want to ensure that you adhere to the principle of least privilege when providing relevant team members with access to Stackdriver Workspaces. What should you do?
- A. Choose an existing GCP production project to host the monitoring workspace. Attach the production projects to this workspace. Grant relevant team members read access to the Stackdriver Workspace.
- B. Grant relevant team members read access to all GCP production projects. Create Stackdriver workspaces inside each project.
- C. Create a new GCP monitoring project, and create a Stackdriver Workspace inside it. Attach the production projects to this workspace. Grant relevant team members read access to the Stackdriver Workspace.
- D. Grant relevant team members the Project Viewer IAM role on all GCP production projects. Create Slackdriver workspaces inside each project.
Answer: A
NEW QUESTION # 68
You need to enforce several constraint templates across your Google Kubernetes Engine (GKE) clusters. The constraints include policy parameters, such as restricting the Kubernetes API. You must ensure that the policy parameters are stored in a GitHub repository and automatically applied when changes occur. What should you do?
- A. Set up a GitHub action to trigger Cloud Build when there is a parameter change. In Cloud Build, run a gcloud CLI command to apply the change.
- B. When there is a change in GitHub, use a web hook to send a request to Anthos Service Mesh, and apply the change.
- C. Configure Config Connector with the GitHub repository. When there is a change in the repository, use Config Connector to apply the change.
- D. Configure Anthos Config Management with the GitHub repository. When there is a change in the repository, use Anthos Config Management to apply the change.
Answer: D
Explanation:
Explanation
The correct answer is C. Configure Anthos Config Management with the GitHub repository. When there is a change in the repository, use Anthos Config Management to apply the change.
According to the web search results, Anthos Config Management is a service that lets you manage the configuration of your Google Kubernetes Engine (GKE) clusters from a single source of truth, such as a GitHub repository1. Anthos Config Management can enforce several constraint templates across your GKE clusters by using Policy Controller, which is a feature that integrates the Open Policy Agent (OPA) Constraint Framework into Anthos Config Management2. Policy Controller can apply constraints that include policy parameters, such as restricting the Kubernetes API3. To use Anthos Config Management and Policy Controller, you need to configure them with your GitHub repository and enable the sync mode4. When there is a change in the repository, Anthos Config Management will automatically sync and apply the change to your GKE clusters5.
The other options are incorrect because they do not use Anthos Config Management and Policy Controller.
Option A is incorrect because it uses a GitHub action to trigger Cloud Build, which is a service that executes your builds on Google Cloud Platform infrastructure6. Cloud Build can run a gcloud CLI command to apply the change, but it does not use Anthos Config Management or Policy Controller. Option B is incorrect because it uses a web hook to send a request to Anthos Service Mesh, which is a service that provides a uniform way to connect, secure, monitor, and manage microservices on GKE clusters7. Anthos Service Mesh can apply the change, but it does not use Anthos Config Management or Policy Controller. Option D is incorrect because it uses Config Connector, which is a service that lets you manage Google Cloud resources through Kubernetes configuration. Config Connector can apply the change, but it does not use Anthos Config Management or Policy Controller.
NEW QUESTION # 69
You recently noticed that one Of your services has exceeded the error budget for the current rolling window period. Your company's product team is about to launch a new feature. You want to follow Site Reliability Engineering (SRE) practices.
What should you do?
- A. Notify the team that their error budget is used up. Negotiate with the team for a launch freeze or tolerate a slightly worse user experience.
- B. Escalate the situation and request additional error budget.
- C. Notify the team about the lack of error budget and ensure that all their tests are successful so the launch will not further risk the error budget.
- D. Look through other metrics related to the product and find SLOs with remaining error budget.
Reallocate the error budgets and allow the feature launch.
Answer: A
Explanation:
Explanation
The correct answer is A. Notify the team that their error budget is used up. Negotiate with the team for a launch freeze or tolerate a slightly worse user experience.
According to the Site Reliability Engineering (SRE) practices, an error budget is the amount of unreliability that a service can tolerate without harming user satisfaction1. An error budget is derived from the service-level objectives (SLOs), which are the measurable goals for the service quality2. When a service exceeds its error budget, it means that it has violated its SLOs and may have negatively impacted the users. In this case, the SRE team should notify the product team that their error budget is used up and negotiate with them for a launch freeze or a lower SLO3. A launch freeze means that no new features are deployed until the service reliability is restored. A lower SLO means that the product team accepts a slightly worse user experience in exchange for launching new features. Both options require a trade-off between reliability and innovation, and should be agreed upon by both teams.
The other options are incorrect because they do not follow the SRE practices. Option B is incorrect because it violates the principle of error budget autonomy, which means that each service should have its own error budget and SLOs, and should not borrow or reallocate them from other services4. Option C is incorrect because it does not address the root cause of the error budget overspend, and may create unrealistic expectations for the service reliability. Option D is incorrect because it does not prevent the possibility of introducing new errors or bugs with the feature launch, which may further degrade the service quality and user satisfaction.
NEW QUESTION # 70
You support a high-traffic web application that runs on Google Cloud Platform (GCP). You need to measure application reliability from a user perspective without making any engineering changes to it. What should you do?
Choose 2 answers
- A. Modify the code to capture additional information for user interaction.
- B. Review current application metrics and add new ones as needed.
- C. Use current and historic Request Logs to trace customer interaction with the application.
- D. Analyze the web proxy logs only and capture response time of each request.
- E. Create new synthetic clients to simulate a user journey using the application.
Answer: A,E
NEW QUESTION # 71
You support a high-traffic web application with a microservice architecture. The home page of the application displays multiple widgets containing content such as the current weather, stock prices, and news headlines. The main serving thread makes a call to a dedicated microservice for each widget and then lays out the homepage for the user. The microservices occasionally fail; when that happens, the serving thread serves the homepage with some missing content. Users of the application are unhappy if this degraded mode occurs too frequently, but they would rather have some content served instead of no content at all. You want to set a Service Level Objective (SLO) to ensure that the user experience does not degrade too much. What Service Level Indicator {SLI) should you use to measure this?
- A. A latency SLI: the ratio of microservice calls that complete in under 100 ms to the total number of microservice calls
- B. A quality SLI: the ratio of non-degraded responses to total responses
- C. A freshness SLI: the proportion of widgets that have been updated within the last 10 minutes
- D. An availability SLI: the ratio of healthy microservices to the total number of microservices
Answer: D
NEW QUESTION # 72
You are designing a deployment technique for your applications on Google Cloud. As part Of your deployment planning, you want to use live traffic to gather performance metrics for new versions Of your applications. You need to test against the full production load before your applications are launched. What should you do?
- A. Use shadow testing with continuous deployment.
- B. Use A/B testing with blue/green deployment.
- C. Use canary testing with rolling updates deployment,
- D. Use canary testing with continuous deployment.
Answer: A
Explanation:
Explanation
The correct answer is B. Use shadow testing with continuous deployment.
Shadow testing is a deployment technique that involves routing a copy of the live traffic to a new version of the application, without affecting the production environment. This way, you can gather performance metrics and compare them with the current version, without exposing the new version to the users. Shadow testing can help you test against the full production load and identify any issues or bottlenecks before launching the new version. You can use continuous deployment to automate the process of deploying the new version after it passes the shadow testing.
NEW QUESTION # 73
Your development team has created a new version of their service's API. You need to deploy the new versions of the API with the least disruption to third-party developers and end users of third-party installed applications. What should you do?
- A. Announce deprecation of the old version of the API.
Introduce the new version of the API.
Contact remaining users on the old API.
Deprecate the old version of the API.
Turn down the old version of the API.
Provide best effort support to users of the old API. - B. Introduce the new version of the API.
Contact remaining users of the old API.
Announce deprecation of the old version of the API.
Deprecate the old version of the API.
Turn down the old version of the API.
Provide best effort support to users of the old API. - C. Introduce the new version of the API.
Announce deprecation of the old version of the API.
Deprecate the old version of the API.
Contact remaining users of the old API.
Provide best effort support to users of the old API.
Turn down the old version of the API. - D. Announce deprecation of the old version of the API.
Contact remaining users on the old API.
Introduce the new version of the API.
Deprecate the old version of the API.
Provide best effort support to users of the old API.
Turn down the old version of the API.
Answer: C
NEW QUESTION # 74
Your team has recently deployed an NGINX-based application into Google Kubernetes Engine (GKE) and has exposed it to the public via an HTTP Google Cloud Load Balancer (GCLB) ingress. You want to scale the deployment of the application's frontend using an appropriate Service Level Indicator (SLI). What should you do?
- A. Configure the horizontal pod autoscaler to use the average response time from the Liveness and Readiness probes.
- B. Configure the vertical pod autoscaler in GKE and enable the cluster autoscaler to scale the cluster as pods expand.
- C. Expose the NGINX stats endpoint and configure the horizontal pod autoscaler to use the request metrics exposed by the NGINX deployment.
- D. Install the Stackdriver custom metrics adapter and configure a horizontal pod autoscaler to use the number of requests provided by the GCLB.
Answer: B
NEW QUESTION # 75
You are investigating issues in your production application that runs on Google Kubernetes Engine (GKE).
You determined that the source Of the issue is a recently updated container image, although the exact change in code was not identified. The deployment is currently pointing to the latest tag. You need to update your cluster to run a version of the container that functions as intended. What should you do?
- A. Alter the deployment to point to the sha2 56 digest of the previously working container.
- B. Create a new tag called stable that points to the previously working container, and change the deployment to point to the new tag.
- C. Build a new container from a previous Git tag, and do a rolling update on the deployment to the new container.
- D. Apply the latest tag to the previous container image, and do a rolling update on the deployment.
Answer: A
NEW QUESTION # 76
Your application services run in Google Kubernetes Engine (GKE). You want to make sure that only images from your centrally-managed Google Container Registry (GCR) image registry in the altostrat-images project can be deployed to the cluster while minimizing development time. What should you do?
- A. Add logic to the deployment pipeline to check that all manifests contain only images from gcr.io/altostrat- images.
- B. Use a Binary Authorization policy that includes the whitelist name pattern gcr.io/altostrat-images/.
- C. Create a custom builder for Cloud Build that will only push images to gcr.io/altostrat-images.
- D. Add a tag to each image in gcr.io/altostrat-images and check that this tag is present when the image is deployed.
Answer: D
NEW QUESTION # 77
You support a production service that runs on a single Compute Engine instance. You regularly need to spend time on recreating the service by deleting the crashing instance and creating a new instance based on the relevant image. You want to reduce the time spent performing manual operations while following Site Reliability Engineering principles. What should you do?
- A. File a bug with the development team so they can find the root cause of the crashing instance.
- B. Add a Load Balancer in front of the Compute Engine instance and use health checks to determine the system status.
- C. Create a Stackdriver Monitoring dashboard with SMS alerts to be able to start recreating the crashed instance promptly after it has crashed.
- D. Create a Managed Instance Group with a single instance and use health checks to determine the system status.
Answer: D
NEW QUESTION # 78
Your company runs an ecommerce website built with JVM-based applications and microservice architecture in Google Kubernetes Engine (GKE) The application load increases during the day and decreases during the night Your operations team has configured the application to run enough Pods to handle the evening peak load You want to automate scaling by only running enough Pods and nodes for the load What should you do?
- A. Configure the Vertical Pod Autoscaler and enable the cluster autoscaler
- B. Configure the Vertical Pod Autoscaler but keep the node pool size static
- C. Configure the Horizontal Pod Autoscaler and enable the cluster autoscaler
- D. Configure the Horizontal Pod Autoscaler but keep the node pool size static
Answer: C
Explanation:
Explanation
The best option for automating scaling by only running enough Pods and nodes for the load is to configure the Horizontal Pod Autoscaler and enable the cluster autoscaler. The Horizontal Pod Autoscaler is a feature that automatically adjusts the number of Pods in a deployment or replica set based on observed CPU utilization or custom metrics. The cluster autoscaler is a feature that automatically adjusts the size of a node pool based on the demand for node capacity. By using both features together, you can ensure that your application runs enough Pods to handle the load, and that your cluster runs enough nodes to host the Pods. This way, you can optimize your resource utilization and cost efficiency.
NEW QUESTION # 79
You manage an application that runs in Google Kubernetes Engine (GKE) and uses the blue/green deployment methodology Extracts of the Kubernetes manifests are shown below
The Deployment app-green was updated to use the new version of the application During post-deployment monitoring you notice that the majority of user requests are failing You did not observe this behavior in the testing environment You need to mitigate the incident impact on users and enable the developers to troubleshoot the issue What should you do?
- A. Change the selector on the Service app-svc to app: my-app, version: blue
- B. Update the Deployment ape-green to use the previous version of the application
- C. Change the selector on the Service app-2vc to app: my-app.
- D. Update the Deployment app-blue to use the new version of the application
Answer: A
Explanation:
Explanation
The best option for mitigating the incident impact on users and enabling the developers to troubleshoot the issue is to change the selector on the Service app-svc to app: my-app, version: blue. A Service is a resource that defines how to access a set of Pods. A selector is a field that specifies which Pods are selected by the Service. By changing the selector on the Service app-svc to app: my-app, version: blue, you can ensure that the Service only routes traffic to the Pods that have both labels app: my-app and version: blue. These Pods belong to the Deployment app-blue, which uses the previous version of the application. This way, you can mitigate the incident impact on users by switching back to the working version of the application. You can also enable the developers to troubleshoot the issue with the new version of the application in the Deployment app-green without affecting users.
NEW QUESTION # 80
You support a user-facing web application. When analyzing the application's error budget over the previous six months, you notice that the application has never consumed more than 5% of its error budget in any given time window. You hold a Service Level Objective (SLO) review with business stakeholders and confirm that the SLO is set appropriately. You want your application's SLO to more closely reflect its observed reliability.
What steps can you take to further that goal while balancing velocity, reliability, and business needs? (Choose two.)
- A. Announce planned downtime to consume more error budget, and ensure that users are not depending on a tighter SLO.
- B. Add more serving capacity to all of your application's zones.
- C. Implement and measure additional Service Level Indicators (SLIs) fro the application.
- D. Tighten the SLO match the application's observed reliability.
- E. Have more frequent or potentially risky application releases.
Answer: A,C
Explanation:
Explanation
https://sre.google/sre-book/service-level-objectives/
You want the application's SLO to more closely reflect it's observed reliability. The key here is error budget never goes over 5%. This means they can have additional downtime and still stay within their budget.
NEW QUESTION # 81
You are building and deploying a microservice on Cloud Run for your organization Your service is used by many applications internally You are deploying a new release, and you need to test the new version extensively in the staging and production environments You must minimize user and developer impact. What should you do?
- A. Deploy the new version of the service to the staging environment with a new-release tag without serving traffic Test the new-release version If the test passes; gradually roll out this tagged version Repeat for the production environment
- B. Deploy the new version of the service to the staging environment Split the traffic, and allow 1 % of traffic through to the latest version Test the latest version If the test passes gradually roll out the latest version to the staging and production environments
- C. Deploy the new version of the service to the staging environment Split the traffic, and allow 50% of traffic through to the latest version Test the latest version If the test passes, send all traffic to the latest version Repeat for the production environment
- D. Deploy a new environment with the green tag to use as the staging environment Deploy the new version of the service to the green environment and test the new version If the tests pass, send all traffic to the green environment and delete the existing staging environment Repeat for the production environment
Answer: A
Explanation:
Explanation
The best option for deploying a new release of your microservice on Cloud Run and testing it extensively in the staging and production environments with minimal user and developer impact is to deploy the new version of the service to the staging environment with a new-release tag without serving traffic, test the new-release version, and if the test passes, gradually roll out this tagged version. A tag is a label that you can assign to a revision of your service on Cloud Run. You can use tags to create different versions of your service without affecting traffic. You can also use tags to gradually roll out traffic to a new version of your service by using traffic splitting. This way, you can test your new release extensively in both environments and minimize user and developer impact.
NEW QUESTION # 82
You need to reduce the cost of virtual machines (VM| for your organization. After reviewing different options, you decide to leverage preemptible VM instances. Which application is suitable for preemptible VMs?
- A. A scalable in-memory caching system
- B. A distributed, eventually consistent NoSQL database cluster with sufficient quorum
- C. The organization's public-facing website
- D. A GPU-accelerated video rendering platform that retrieves and stores videos in a storage bucket
Answer: D
Explanation:
Explanation
https://cloud.google.com/compute/docs/instances/preemptible
NEW QUESTION # 83
You are responsible for the reliability of a high-volume enterprise application. A large number of users report that an important subset of the application's functionality - a data intensive reporting feature - is consistently failing with an HTTP 500 error. When you investigate your application's dashboards, you notice a strong correlation between the failures and a metric that represents the size of an internal queue used for generating reports. You trace the failures to a reporting backend that is experiencing high I/O wait times. You quickly fix the issue by resizing the backend's persistent disk (PD). How you need to create an availability Service Level Indicator (SLI) for the report generation feature. How would you define it?
- A. As the proportion of report generation requests that result in a successful response
- B. As the application's report generation queue size compared to a known-good threshold
- C. As the I/O wait times aggregated across all report generation backends
- D. As the reporting backend PD throughout capacity compared to a known-good threshold
Answer: A
Explanation:
According to SRE Workbook, one of potential SLI is as below:
* Type of service: Request-driven
* Type of SLI: Availability
* Description: The proportion of requests that resulted in a successful response.
https://sre.google/workbook/implementing-slos/
NEW QUESTION # 84
......
The Most In-Demand Professional-Cloud-DevOps-Engineer Pass Guaranteed Quiz : https://examcollection.dumpsvalid.com/Professional-Cloud-DevOps-Engineer-brain-dumps.html